mengatasi error “not authorized to perform operation” xfce4 di archlinux


polkit-gnome

failed to mount "229 GB Volume "

not authorized to perform operation

penampakan error di archlinux 32 bit xfce4 saya. disaat saya mau mengakses partisi lainya.,
padahal di xubuntu tidak ada error seperti ini?

disini saya tidak mengistall display manager, seperti lightdm,gdm,kdm,dll…
saya lebih suka mengunakan “startx”  :)

menurut saya ada 3 cara untuk menyelesaikan error di atas :

1. membuat mount point : ( manual  mounting , )

$ sudo mount /dev/sdax /mnt/mountpoint
atau
$ sudo mount -t ntfs-3g /dev/sdax  / /mnt/mountpoint


2. edit fstab ( auto mounting  )

$ sudo nano /etc/fstab

3. menginstall “polikit-gnome”

nah.. cara ke 3 ini yang saya lebih suka,
berikut langkah2nya,:

– remove thunar-volman dan install polkit-gnome,gvfs

$ sudo pacman -R thunar-volman (sudah usang)
$ sudo pacman -S polkit-gnome
$ sudo pacman -S gvfs

– membuat “polkit-gnome” berjalan saat boot,( add statrtup )

startupdengan command

/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1

cek polkit yang berjalan :

$ ps x | grep polkit
 2839 pts/1    Sl+    0:00 /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1
 2842 pts/2    S+     0:00 grep --color=auto polkit

Reboot….

hasil :

polkit-gnome2

Selesai…🙂

tangkapan aktivitas terminal saya ( tentang polkit )


pacman -Ss thunar-volman
extra/thunar-volman 0.8.0-1 (xfce4) [installed]
 Automatic management of removeable devices in Thunar
┌─[ariyasa@archlinux]─[~]
└──╼ pacman -Ss lxpolkit
community/lxpolkit 0.1.0-3 (lxde)
 Simple polkit authentication agent for LXDE
┌─[ariyasa@archlinux]─[~]
└──╼ pacman -Ss polkit-gnome
community/polkit-gnome 0.105-2 [installed]
 Legacy polkit authentication agent for GNOME
┌─[ariyasa@archlinux]─[~]
└──╼ pacman -Ss polkit-kde
extra/polkit-kde 0.99.0-2 [installed]
 Daemon providing a polkit authentication UI for KDE

sumber :

https://wiki.archlinux.org/index.php/Polkit#Installation
https://bbs.archlinux.org/viewtopic.php?id=137791

2 thoughts on “mengatasi error “not authorized to perform operation” xfce4 di archlinux

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s